Wednesday, April 29, 2015

Install Oracle Database 10gR2 on Oracle Linux 5 (Part II)

Situation:
When installing Oracle Database 10gR2 on Oracle Linux 5 you will find the following error:
[oracle@test database]$ ./runInstaller
Starting Oracle Universal Installer...
Checking installer requirements...
Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
Failed <<<<
Exiting Oracle Universal Installer, log for this session can be found at /tmp/OraInstall2015-04-19_09-45-17AM/installActions2015-04-19_09-45-17AM.log
Cause:
Originally, Red Hat 5 was not supported by Oracle Database 10gR2.

Solution:
Editar el script /install/oraparam.ini para agregar la línea que incluye al sistema operativo:
[Certified Versions] Linux=redhat-3,SuSE-9,redhat-4,UnitedLinux-1.0,asianux-1,asianux-2,redhat-5

Install Oracle Database 10gR2 on Oracle Linux 5 (Part I)

Situation:
When executing the runInstaller.sh for installing Oracle Database 10gR2 on Oracle Linux 5, I got the following exception:
Exception java.lang.UnsatisfiedLinkError: /tmp/OraInstall2015-04-17_09-36-15AM/jre/1.4.2/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory occurred.
Cause:
Missing deprecated dependencies.

Solution:
Install these packages using YUM or the installation media: xorg-x11-deprecated-libs y libXp.